Parsable Academy Login Issues

Incident Report for Parsable

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 18:15 UTC

Monitoring

The issue looks to be resolved by our vendor. Please let us know if you are still unable to access Parsable Academy (academy.parsable.com).
Posted Feb 18, 2026 - 18:22 UTC

Identified

We are aware of an issue accessing Parsable Academy (academy.parsable.com). When logging in, you may see this error "403 Forbidden"
This is due to a vendor issue which we are actively monitoring: https://status.skilljar.com/

If you have any other related issues to report, please reach out to our support team via help.parsable.com
Posted Feb 18, 2026 - 17:57 UTC
This incident affected: WebEx.