Parsable login issue

Incident Report for Parsable

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 15:32 UTC

Monitoring

Parsable has remediated the issue. All logins have returned to normal for all regions, we will continue to carefully monitor the service to ensure a full recovery for all users.

Thank you for your patience, and we apologize for the inconvenience.
If you have any other related issues to report or are still currently experiencing the issue, please reach out to our support team via help.parsable.com
Posted Mar 17, 2025 - 12:00 UTC

Identified

We have identified the Parsable platform as being unavailable for US region teams. EU teams should be unaffected.
We will continue to provide updates as we have them. We appreciate your patience as we work to resolve this issue.
Posted Mar 17, 2025 - 11:54 UTC

Investigating

Parsable is currently investigating an issue logging in to the Parsable application on both mobile and web.

While we do not have an ETA for a resolution, we are actively investigating and will provide updates here.

We thank you for your patience as we continue to look into this issue.
If you have any other related issues to report, please reach out to our support team via help.parsable.com
Posted Mar 17, 2025 - 11:40 UTC
This incident affected: WebEx and Mobile.